#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?s)\n[^\n]*start[^\n]*\n((?:.(?!start))*?)\n[^\n]*end"
Local $sString = "123start123" & @CRLF & _
"1111111111" & @CRLF & _
"4567start4567" & @CRLF & _
"****" & @CRLF & _
"****" & @CRLF & _
"****" & @CRLF & _
"789end789" & @CRLF & _
"1234end1234"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYFULLMATCH)
; Present the entire match result
_ArrayDisplay($aArray, "Result")