using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?s)\n[^\n]*start[^\n]*\n((?:.(?!start))*?)\n[^\n]*end";
string input = @"123start123
1111111111
4567start4567
****
****
****
789end789
1234end1234";
Match m = Regex.Match(input, pattern);
Console.WriteLine("'{0}' found at index {1}", m.Value, m.Index);
}
}