$re = '/(?s)\n[^\n]*start[^\n]*\n((?:.(?!start))*?)\n[^\n]*end/';
$str = '123start123
1111111111
4567start4567
****
****
****
789end789
1234end1234';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);