using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"[{][0-9a-fA-F]{8}[-](?>[0-9a-fA-F]{4}[-]){3}[0-9a-fA-F]{12}[}]";
string input = @"MsiExec.exe /I{7E8B9F22-63F2-4AE1-A815-71680B8E9C52} /qn";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}