$re = '/[{][0-9a-fA-F]{8}[-](?>[0-9a-fA-F]{4}[-]){3}[0-9a-fA-F]{12}[}]/m';
$str = 'MsiExec.exe /I{7E8B9F22-63F2-4AE1-A815-71680B8E9C52} /qn';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);