use strict;
my $str = 'MsiExec.exe /I{7E8B9F22-63F2-4AE1-A815-71680B8E9C52} /qn';
my $regex = qr/[{][0-9a-fA-F]{8}[-](?>[0-9a-fA-F]{4}[-]){3}[0-9a-fA-F]{12}[}]/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}