#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^([A-Z]{1,3})\h+([A-Z]{1,3})[-*][A-Z]{5}$"
Local $sString = "D HG-ABCDE : Country should be D, District should be HG" & @CRLF & _
"A S-FGHIJ : Country should be A, District should be S " & @CRLF & _
"D AC-KLMNO : Country should be D, District should be AC" & @CRLF & _
"A BR-PQRST : Country should be A, District should be BR" & @CRLF & _
"A RO*UVWXY : Country should be A, District should be RO" & @CRLF & _
"" & @CRLF & _
"D HG-ABCDE" & @CRLF & _
"A S-FGHIJ" & @CRLF & _
"D AC-KLMNO" & @CRLF & _
"A BR-PQRST" & @CRLF & _
"A RO*UVWXY"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")