package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^([A-Z]{1,3})\h+([A-Z]{1,3})[-*][A-Z]{5}$`)
var str = `D HG-ABCDE : Country should be D, District should be HG
A S-FGHIJ : Country should be A, District should be S
D AC-KLMNO : Country should be D, District should be AC
A BR-PQRST : Country should be A, District should be BR
A RO*UVWXY : Country should be A, District should be RO
D HG-ABCDE
A S-FGHIJ
D AC-KLMNO
A BR-PQRST
A RO*UVWXY`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}