using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^([A-Z]{1,3})\h+([A-Z]{1,3})[-*][A-Z]{5}$";
string input = @"D HG-ABCDE : Country should be D, District should be HG
A S-FGHIJ : Country should be A, District should be S
D AC-KLMNO : Country should be D, District should be AC
A BR-PQRST : Country should be A, District should be BR
A RO*UVWXY : Country should be A, District should be RO
D HG-ABCDE
A S-FGHIJ
D AC-KLMNO
A BR-PQRST
A RO*UVWXY";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}