#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?mi)(?=(^(?!.*(Hello|World)).*))^(Test|Sample)($|.*(?=(Good|Stuff)).*$)"
Local $sString = "Test" & @CRLF & _
"Test Good" & @CRLF & _
"Sample Stuff " & @CRLF & _
"Test Hello " & @CRLF & _
"Sample World " & @CRLF & _
"Test Hello Stuff " & @CRLF & _
"Sample Good World" & @CRLF & _
"Test Other" & @CRLF & _
"Test Other Stuff " & @CRLF & _
"Test Other Stuff Other" & @CRLF & _
"Sample Other World"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")