re = /(?=(^(?!.*(Hello|World)).*))^(Test|Sample)($|.*(?=(Good|Stuff)).*$)/mi
str = 'Test
Test Good
Sample Stuff
Test Hello
Sample World
Test Hello Stuff
Sample Good World
Test Other
Test Other Stuff
Test Other Stuff Other
Sample Other World'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end