import re
regex = re.compile(r"(?=(^(?!.*(Hello|World)).*))^(Test|Sample)($|.*(?=(Good|Stuff)).*$)", flags=re.MULTILINE | re.IGNORECASE)
test_str = ("Test\n"
"Test Good\n"
"Sample Stuff \n"
"Test Hello \n"
"Sample World \n"
"Test Hello Stuff \n"
"Sample Good World\n"
"Test Other\n"
"Test Other Stuff \n"
"Test Other Stuff Other\n"
"Sample Other World")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")