#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^[\w\d\s]{23}([\d\s]{1,4}).*$"
Local $sString = "Name 1 N ASHA A 2 35 23 " & @CRLF & _
"Name 2 R MONA A 3 25 56 " & @CRLF & _
"Name 3 P TERY A 15 23 32 " & @CRLF & _
"Name 4 Q JACK A 25 56 25 " & @CRLF & _
"Name 5 D TOM A 115 57 45 " & @CRLF & _
"Name 3 P SEN A1215 45 56 "
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")