import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^[\\w\\d\\s]{23}([\\d\\s]{1,4}).*$";
final String string = "Name 1 N ASHA A 2 35 23 \n"
+ "Name 2 R MONA A 3 25 56 \n"
+ "Name 3 P TERY A 15 23 32 \n"
+ "Name 4 Q JACK A 25 56 25 \n"
+ "Name 5 D TOM A 115 57 45 \n"
+ "Name 3 P SEN A1215 45 56 ";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}