package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^[\w\d\s]{23}([\d\s]{1,4}).*$`)
var str = `Name 1 N ASHA A 2 35 23
Name 2 R MONA A 3 25 56
Name 3 P TERY A 15 23 32
Name 4 Q JACK A 25 56 25
Name 5 D TOM A 115 57 45
Name 3 P SEN A1215 45 56 `
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}