const regex = /(<table>)\|(<tr>)\[<td>([^<]*)<\/td>\](<\/tr>)\|(<\/table>)/;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(<table>)\\|(<tr>)\\[<td>([^<]*)<\\\/td>\\](<\\\/tr>)\\|(<\\\/table>)', '')
const str = `<table>|<tr>[<td>outro valor</td>]</tr>|</table>`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}