re = /(<table>)\|(<tr>)\[<td>([^<]*)<\/td>\](<\/tr>)\|(<\/table>)/
str = '<table>|<tr>[<td>outro valor</td>]</tr>|</table>'
# Print the match result
str.match(re) do |match|
puts match.to_s
end