using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"['\""](name|anotherkey)['\""]\s*=\s*(?:'([^']*)'|\""([^\""]*)\"")";
string input = @"atable['akeyofthetable'] = { 'name' = 'a name',
'thevalue' = 34,
""anotherkey"" = 'something' }";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}