package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`['\"](name|anotherkey)['\"]\s*=\s*(?:'([^']*)'|\"([^\"]*)\")`)
var str = `atable['akeyofthetable'] = { 'name' = 'a name',
'thevalue' = 34,
"anotherkey" = 'something' }`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}