using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"[^.!]([""'])(?:(?=(\\?))\2.)*?\1";
string input = @"""Took 0 seconds""
This is some other content ""Took 0 seconds"" and some more content
Some more content ""Took 1 seconds"" and more content";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}