use strict;
my $str = '"Took 0 seconds"
This is some other content "Took 0 seconds" and some more content
Some more content "Took 1 seconds" and more content';
my $regex = qr/[^.!](["'])(?:(?=(\\?))\2.)*?\1/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}