$re = '/[^.!](["\'])(?:(?=(\\\\?))\2.)*?\1/m';
$str = '"Took 0 seconds"
This is some other content "Took 0 seconds" and some more content
Some more content "Took 1 seconds" and more content';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);