using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"<(\w+)\s*[^>]*>|.(?=([^><]*<[^>]*>)*[^<>]*$)";
string substitution = @"$1";
string input = @"abc<div style=""left:100px;"" > some <div>MyText, <strong> hgz uz <em> Some text for flrdm <p><b>b, <p> <p><h4><h1><span id=""MySpan"">any text, ";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}