re = /<(\w+)\s*[^>]*>|.(?=([^><]*<[^>]*>)*[^<>]*$)/m
str = 'abc<div style="left:100px;" > some <div>MyText, <strong> hgz uz <em> Some text for flrdm <p><b>b, <p> <p><h4><h1><span id="MySpan">any text, '
subst = '$1'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result