const regex = /<(\w+)\s*[^>]*>|.(?=([^><]*<[^>]*>)*[^<>]*$)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('<(\\w+)\\s*[^>]*>|.(?=([^><]*<[^>]*>)*[^<>]*$)', 'gm')
const str = `abc<div style="left:100px;" > some <div>MyText, <strong> hgz uz <em> Some text for flrdm <p><b>b, <p> <p><h4><h1><span id="MySpan">any text, `;
const subst = `$1`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);