package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`\s*(\w+)\s*{\s*([^}]*?)\s*}`)
var str = `
p {
color:red;
}
p {
color:blue;
}
img {
max-width: 200px;
}
img {
display: block;
}
p {
color:green;
}
p {
font-weight: normal;
}`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}