import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\s*(\\w+)\\s*\\{\\s*([^\\}]*?)\\s*\\}";
final String string = "\n"
+ " p {\n"
+ " color:red;\n"
+ " }\n\n"
+ " p {\n"
+ " color:blue;\n"
+ " }\n"
+ " img {\n"
+ " max-width: 200px;\n"
+ " }\n\n"
+ "img {\n"
+ " display: block;\n"
+ "}\n"
+ " p {\n"
+ " color:green;\n"
+ " }\n\n"
+ "p {\n"
+ " font-weight: normal;\n"
+ "}";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}