$re = '/\s*(\w+)\s*{\s*([^}]*?)\s*}/';
$str = '
p {
color:red;
}
p {
color:blue;
}
img {
max-width: 200px;
}
img {
display: block;
}
p {
color:green;
}
p {
font-weight: normal;
}';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);