$re = '~([\'"]).*?\1(*SKIP)(*FAIL)|\s*\|\s*~m';
$str = 'aa | bb | "cc | dd" | \'ee | ff\'';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);