import Foundation
let pattern = #"\$[^\$]*\$"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
$hello$
$
hello
$
.projection $I_{d,i} \rightarrow M_{d,i} M_{d,0}$, where all the
\begin{itemize}
\item $M$ is atomic and finitely generated;
\item $M$ is cancellative;
\item $(M, \le_L)$ and $(M, \le_R)$ are lattices;
\item there exists an element $\Delta \in M$, called {\it Garside element}, such that the set
$L(\Delta)= \{ x \in M; x\le_L \Delta\}$ generates $M$ and is equal to $R(\Delta)= \{ x\in M;
x\le_R \Delta\}$.
\end{itemize}
Using the fact that is atomic and that $L(\Delta)=
\{x \in M; x \le_L \Delta\} M \pi_L(a) \neq 1 a \neq
1 k \partial_L^k(a)=1 k$ be the
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #" "#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)