import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(\\d+\\.\\d+\\.\\d+\\.\\d+).*\\[(.+)\\].*?\"([A-Z]+)\\s(\\S+)\\s(HTTP/\\d+\\.\\d+).*?(\\d+)\\s(\\d+).*?(\\d+)\\}";
final String string = "{\"resource\":{\"attributes\":{}},\"scope\":{\"attributes\":{}},\"logRecord\":{\"attributes\":{\"log.file.name\":\"xxxx.log\",\"log.file.path\":\"X:\\\\xxx\\\\xxxx.log\"},\"body\":\"1.1.1.1 - - [04/Mar/2023:23:16:59 +0000] \\\"HEAD /xxxx-xxxxx%20systematic%20internet%20solution_xxx-xxx.png HTTP/1.1\\\" 200 1091 \\\"-\\\" \\\"Mozilla/5.0 (Windows 95) AppleWebKit/5361 (KHTML, like Gecko) Chrome/36.0.849.0 Mobile Safari/5361\\\"\",\"observedTimeUnixNano\":1716203580594785300}}";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}