import Foundation
let pattern = #"(\d+\.\d+\.\d+\.\d+).*\[(.+)\].*?"([A-Z]+)\s(\S+)\s(HTTP/\d+\.\d+).*?(\d+)\s(\d+).*?(\d+)}"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"{"resource":{"attributes":{}},"scope":{"attributes":{}},"logRecord":{"attributes":{"log.file.name":"xxxx.log","log.file.path":"X:\\xxx\\xxxx.log"},"body":"1.1.1.1 - - [04/Mar/2023:23:16:59 +0000] \"HEAD /xxxx-xxxxx%20systematic%20internet%20solution_xxx-xxx.png HTTP/1.1\" 200 1091 \"-\" \"Mozilla/5.0 (Windows 95) AppleWebKit/5361 (KHTML, like Gecko) Chrome/36.0.849.0 Mobile Safari/5361\"","observedTimeUnixNano":1716203580594785300}}"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)