# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"(\d+\.\d+\.\d+\.\d+).*\[(.+)\].*?\"([A-Z]+)\s(\S+)\s(HTTP/\d+\.\d+).*?(\d+)\s(\d+).*?(\d+)}"
test_str = "{\"resource\":{\"attributes\":{}},\"scope\":{\"attributes\":{}},\"logRecord\":{\"attributes\":{\"log.file.name\":\"xxxx.log\",\"log.file.path\":\"X:\\\\xxx\\\\xxxx.log\"},\"body\":\"1.1.1.1 - - [04/Mar/2023:23:16:59 +0000] \\\"HEAD /xxxx-xxxxx%20systematic%20internet%20solution_xxx-xxx.png HTTP/1.1\\\" 200 1091 \\\"-\\\" \\\"Mozilla/5.0 (Windows 95) AppleWebKit/5361 (KHTML, like Gecko) Chrome/36.0.849.0 Mobile Safari/5361\\\"\",\"observedTimeUnixNano\":1716203580594785300}}"
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.