using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"<img(?=\s)(?=(?:[^>""']|""[^""]*""|'[^']*')*?\ssrc\s*=\s*(?:(['""])([\S\s]*?)\1))\s+(?:""[\S\s]*?""|'[\S\s]*?'|[^>]*?)+>";
string input = @"<a><img src=""imagsource.jpg""width=""imageWidth /></a>";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}