$re = '/<img(?=\s)(?=(?:[^>"\']|"[^"]*"|\'[^\']*\')*?\ssrc\s*=\s*(?:([\'"])([\S\s]*?)\1))\s+(?:"[\S\s]*?"|\'[\S\s]*?\'|[^>]*?)+>/m';
$str = '<a><img src="imagsource.jpg"width="imageWidth /></a>';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);