re = /<img(?=\s)(?=(?:[^>"']|"[^"]*"|'[^']*')*?\ssrc\s*=\s*(?:(['"])([\S\s]*?)\1))\s+(?:"[\S\s]*?"|'[\S\s]*?'|[^>]*?)+>/m
str = '<a><img src="imagsource.jpg"width="imageWidth /></a>'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end