re = /.*CSF-([^._]*).*/m
str = 'PG.BiologicalProcess
PG.MolecularFunction
20210427_EXPL2_Evo1_CML_DIA44min_CSF-01-R_49.raw.PG.MS1Quantity
20210427_EXPL2_Evo1_CML_DIA44min_CSF-02-R_50.raw.PG.MS1Quantity
20210608_EXPL2_Evo3_CML_DIA44m_60k15k_CSF-01-30R_109.raw.PG.MS1Quantity
20210608_EXPL2_Evo3_CML_DIA44m_60k15k_CSF-01-Sr.raw.PG.MS1Quantity'
subst = '\\1'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result