#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "companyholder\.do[\S]+symbol\=([\w\d-]+(?=&|\n))"
Local $sString = "https://www.set.or.th/set/companyholder.do?symbol=EMC" & @CRLF & _
"https://www.set.or.th/set/companyholder.do?symbol=EMC&language=th&country=TH" & @CRLF & _
"https://www.set.or.th/set/companyholder.do%3Bjsessionid=B08A576398DF62A466D1D08EAAF280CC?symbol=BLAND-F&language=en&country=EN" & @CRLF & _
"https://www.set.or.th/set/newsdetails.do?newsId=14828768298911&language=th&country=TH" & @CRLF & _
"https://www.set.or.th/set/companyholder.do?symbol=RML-F&ssoPageId=6&language=th&country=TH"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")