import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "companyholder\\.do[\\S]+symbol\\=([\\w\\d-]+(?=&|\\n))";
final String string = "https://www.set.or.th/set/companyholder.do?symbol=EMC\n"
+ "https://www.set.or.th/set/companyholder.do?symbol=EMC&language=th&country=TH\n"
+ "https://www.set.or.th/set/companyholder.do%3Bjsessionid=B08A576398DF62A466D1D08EAAF280CC?symbol=BLAND-F&language=en&country=EN\n"
+ "https://www.set.or.th/set/newsdetails.do?newsId=14828768298911&language=th&country=TH\n"
+ "https://www.set.or.th/set/companyholder.do?symbol=RML-F&ssoPageId=6&language=th&country=TH";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}