package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?mi)\b(\w*^population$\w*)\b`)
var str = `Integration_Population
Population
population
Lookup
lookup`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}