$re = '/\b(\w*^population$\w*)\b/mi';
$str = 'Integration_Population
Population
population
Lookup
lookup';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);