re = /\b(\w*^population$\w*)\b/mi
str = 'Integration_Population
Population
population
Lookup
lookup'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end