package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`\s?(\w+(?:\s\w+)+)\s?`)
var str = `hello world / this / is a / complicated / task / with more words / as well`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}