$re = '/\s?(\w+(?:\s\w+)+)\s?/';
$str = 'hello world / this / is a / complicated / task / with more words / as well';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);