re = /\s?(\w+(?:\s\w+)+)\s?/
str = 'hello world / this / is a / complicated / task / with more words / as well'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end