import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?<service1>^((?!\\d+).)*$)";
final String string = "abc\n"
+ "23\n"
+ "sds\n"
+ "55\n"
+ "dffgdg\n"
+ "13\n"
+ "as\n"
+ "s\n"
+ "xyz\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}