$re = '/(?<service1>^((?!\d+).)*$)/m';
$str = 'abc
23
sds
55
dffgdg
13
as
s
xyz
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);