import re
regex = re.compile(r"(?<service1>^((?!\d+).)*$)", flags=re.MULTILINE)
test_str = ("abc\n"
"23\n"
"sds\n"
"55\n"
"dffgdg\n"
"13\n"
"as\n"
"s\n"
"xyz\n")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")