using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?:\btype|(?!^)\G,)\h*\K[^,\s]*";
string input = @"type MyType1
type MyType2, MyType3
type MyType4, MyType5, MyType6
NotMyType1, NotMyType2";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}