import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?:\\btype|(?!^)\\G,)\\h*\\K[^,\\s]*";
final String string = "type MyType1\n"
+ "type MyType2, MyType3\n"
+ "type MyType4, MyType5, MyType6\n"
+ "NotMyType1, NotMyType2";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}